Не редко провайдеры предоставляют доступ в сеть Интернет по протоколу PPPoE. При таком типе подключения пользователю выдаётся логин и пароль. 

В роли PPPoE клиента может выступать и маршрутизатор Cisco, что бы его настроить нужно:

1. Создать и настроить интерфейс Dialer:

R1(config)#interface Dialer1
R1(config-if)# ip address negotiated
R1(config-if)# ip mtu 1492
R1(config-if)# ip nat outside
R1(config-if)# encapsulation ppp
R1(config-if)# dialer pool 1
R1(config-if)# ppp authentication chap callin
R1(config-if)#ppp chap hostname pppoe_user1
R1(config-if)#ppp chap password 0 cisco
R1(config-if)#exit
R1(config)#

 2. На интерфейсе, который подключен к сети провайдера, задать pppoe-client сопоставленный с созданным выше dialer pool ( его мы указали в интерфейсе Dialer1):

R1(config)#interface FastEthernet0/1
R1(config-if)#pppoe-client dial-pool-number 1
R1(config-if)#exit
R1(config)#

 

3. Задать маршрут по умолчанию через интерфейс Dialer:

R1(config)#ip route 0.0.0.0 0.0.0.0 dialer 1
R1(config)#

 

Пример конфигурации роутера:

R1#sh run
Building configuration...
Current configuration : 1215 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$FOp2$9G9FvXT/lRo1HqKkgwVWv/
!
clock timezone YST 10
aaa new-model
!
!
aaa authentication login default local
aaa session-id common
ip subnet-zero
ip cef
!
!
!
ip domain name test.ru
ip audit po max-events 100
!
!
!
!
!
!
!
!
!
!
!
!
username cisco secret 5 $1$jOx6$M96EAbwK4qcWtGlxHLt3J/
!
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.56.254 255.255.255.0
ip nat inside
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
pppoe enable
pppoe-client dial-pool-number 1
!
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
encapsulation ppp
dialer pool 1
ppp authentication chap callin
ppp chap hostname pppoe_user1
ppp chap password 0 cisco
!
ip nat inside source list 1 interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
!
no ip http server
no ip http secure-server
!
access-list 1 permit 192.168.56.0 0.0.0.255
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
exec-timeout 60 0
transport input telnet ssh
!
end
R1#

 

 

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *